fu: Close-up of Fu, bringing a scoop of water to her mouth (Default)
fu ([personal profile] fu) wrote in [site community profile] dw_beta2011-05-17 02:47 pm
Entry tags:

New changes live

New with this code push, including fixes so that the JS always works even when expanding multiple layers, e.g., even after viewing answers, or after expanding a cut:

  • polls

  • media placeholders

  • contextual hover

  • expand all cut tags module



And a couple of tweaks, chiefly:

  • fix quick reply overlapping content in some layouts

  • make screened/delete/etc work for expanded comments

sarken: leaves of mint against a worn wall (Default)

[personal profile] sarken 2011-12-06 09:04 am (UTC)(link)
Hi, there! The Dreamwidth Beta page says same-page poll submission should be working with the new JS beta, but it isn't working for me. I'm using Safari 5.0.6 on Mac OSX 10.5.8, I have the beta update page turned on as well as the new JS beta, and I'm using the Transmogrified layout with custom CSS, but it works when I turn the new JS beta testing off.
Edited (Clarifying) 2011-12-06 09:05 (UTC)
amadi: A bouquet of dark purple roses (Default)

[personal profile] amadi 2011-12-06 09:11 am (UTC)(link)
I second this, using Firefox 8.0.1 on Mac OSX 10.6.8, though I tested across a half dozen different accounts and only the account that has JS beta and the update page beta testing turned on had the problem, on any layout, custom CSS or otherwise.

Clicking submit on a poll, whether from the basic journal page or from the reading page, automatically forwards to the specific entry that the poll is attached to.
amadi: A bouquet of dark purple roses (Default)

[personal profile] amadi 2011-12-08 05:40 am (UTC)(link)
I took this poll from my reading page, and it did drop me into the entry itself when I clicked submit. There's a bunch of errors in the error log, can I email you a screenshot of it?
amadi: A bouquet of dark purple roses (Default)

[personal profile] amadi 2011-12-08 07:41 am (UTC)(link)
Just sent. Thank you!
sarken: leaves of mint against a worn wall (Default)

[personal profile] sarken 2011-12-06 10:24 am (UTC)(link)
This is pretty odd. I've had it happen at least three times recently -- once from my network, twice from my reading page -- but when I posted a poll to my own journal, it worked fine from the entry page. I went back to me reading list, cleared the answers from a poll I'd had the issue with, filled it out again...and it worked fine. It seems to be an off and on thing for me, with all types of polls. Since it worked fine just now, I didn't see an errors on the error console. If it happens again, I'll check the error console and report back.
sarken: leaves of mint against a worn wall (Default)

[personal profile] sarken 2012-01-16 10:07 am (UTC)(link)
No, I don't have any extensions or scripts I use for Dreamwidth -- but I also haven't seen the problem again, so yay?