denise: Image: Me, facing away from camera, on top of the Castel Sant'Angelo in Rome (Default)
Denise ([staff profile] denise) wrote in [site community profile] dw_beta2011-10-30 11:28 pm
Entry tags:

New Create Entries management page

This post is to report bugs in the new Create Entries page. This is a complete rewrite of the old Update page, in order to allow for future expansion and new features such as draft posts, scheduled posts, recurring posts, expanding the range of what can be posted to your journal, and a whole host of other awesome things.

When reporting bugs, please include:

* The browser name, browser version number, and operating system you're using
* The steps you took to reproduce the problem
* Whether or not you've tested the same steps in another browser (and if so, which)
* Whether you get the same result every time you try the same steps, or if it only happens sometimes

If we can't reproduce the problem under the same browser and operating system, we may also ask you for a list of any browser extensions you have installed.

Not all features are completely implemented in the new Create Entries page yet. The biggest thing currently missing is the Rich Text editor -- the only option is the plain-old-HTML option. The design of the page is geared towards changing concepts and visual/workflow metaphors around what it means to "post an entry", too -- because of the forthcoming draft and scheduled posts, we needed to adapt some of the language and some of the ways we present concepts -- even though the draft and scheduled post functionality isn't ready to be released yet. So, if something looks awkward or like it doesn't quite fit, it's probably there to allow for something we'll be releasing in the future. (You can still mention it, though!)

Things we also consider to be bugs that should be reported, in addition to something not working right:

* if you can't figure out what to do at any step of the update process
* if you have accessibility-related problems (with your screenreader, with the tab order of the page, with the workflow, etc)
* if something about the new workflow completely breaks the way you use your journal, and you can't figure out any way to work around it (there may be a way to do what you're used to doing, but if you can't figure it out, that's something we might change or might want to document, etc)

You can enable or disable beta testing at any point.



Not yet enabled



* Rich Text editing
* Using the new Create Entries page for editing existing entries
* Using the new Create Entries page for comm admins deleting posts or performing admin overrides
* Draft posts of any type, including the in-browser saved drafts that exist right now

Known/Reported Bugs



* some difficulties crossposting, looks like possibly date-related? we're trying to figure it out.

Should be fixed



* Settings not properly saving when using the "gear" customize-this-page popup; some modules disappear
* Create Entries form being repeated after posting an entry
* Error in link to Beta Features at top of page
* Error messages when using new update page in older versions of Firefox
* Difficulties with IE (oh, IE)
* Errors with time being truncated
* inactive icons showing in the icon browser
* minsecurity of journal not reflecting properly in update form
* whole host of display glitches
michelel72: (DS-Quote-TeachToCow)

[personal profile] michelel72 2012-05-03 03:16 am (UTC)(link)
I feel silly asking this, because it's probably obvious, but I don't see it and can't find any references to it by comm search or search-in-page here.

Where's the option to set the comment screening level for a post?

In some of my comms, I need to screen responses to certain posts, to maintain participant anonymity. So far I've been able to post the entries and then use the "edit" function to change the screening level, but obviously that won't work once editing uses the new function.

I'm on Windows XP with IE 8.0.6001.18702. I haven't found the option on this device or on my work PC (also WinXP IE8); I haven't tried other browsers. If the new posting page is customizable, I haven't done any of that, so in theory I'm using whatever defaults for this page. Thanks!

ETA: Sigh, please disregard. After I posted this, I found the comments explaining how to get to the settings. (I don't personally like little word-free icons that hide settings, but that's the Wave of the Future! apparently, so I'll learn to live with disappointment.) Sorry for the clutter.
Edited (Found the answer myself after asking.) 2012-05-03 03:20 (UTC)
michelel72: (Cat-Gonzo-Surprise)

[personal profile] michelel72 2012-05-03 03:31 am (UTC)(link)
Yeah, it was pretty obvious once I saw that. I had taken the gear as part of the poll creation option for some reason. (I'm all old-school; the new Gmail-and-LJ (and probably everyeone else) approach that hides options based on context and discourages text labels makes me sadface. I'm not used to being on the curmudgeonly side of web development for real, heh.)

Thanks for the quick response!
eosrose: (Default)

[personal profile] eosrose 2016-04-02 05:15 pm (UTC)(link)
Where is the Disable Auto-Formatting ticky box in beta posting?
ygam: (Default)

[personal profile] ygam 2017-01-29 08:31 am (UTC)(link)
Auto-saving drafts works with the old page, and doesn't work with the new page.
paragon: (Default)

[personal profile] paragon 2017-02-25 09:34 pm (UTC)(link)
I can't seem to make my icon selection stick from the icon browser. Whether I double click the icon or single click and choose Select, it seems to have no effect and simply stays as my default. Even if I post my entry and then go back to edit it, I have to switch to the old create entry page to select an icon other than my default.

* The browser name, browser version number, and operating system you're using: Chrome 56.0.2924.87, Windows 10
* The steps you took to reproduce the problem: Not sure what this means, but I did try in incognito mode to make sure none of my extensions were the problem and it still happened.
* Whether or not you've tested the same steps in another browser (and if so, which): No, I have no other browsers.
* Whether you get the same result every time you try the same steps, or if it only happens sometimes: Every time.
paragon: (Default)

[personal profile] paragon 2017-02-26 03:39 am (UTC)(link)
This has actually been going on for a while; I just haven't reported it here before. My browser cache has been cleared more than once, but I just tried again and no dice.
siderea: (Default)

Non-Crossposting Bug

[personal profile] siderea 2017-03-04 05:16 am (UTC)(link)
I've defaulted my journal to crossposting to LJ, but not storing the password. When I go to the beta Create Entry page, as expected, my crosspost settings have the "Crosspost This" tickybox ticked, and below that the specific Crosspost To (LJ) tickybox ticked. This is correct.

However, if I don't want to crosspost, and untick the parent "Crosspost This" ticky box, I get the following bug: the child ticky for LJ grays out but remains ticked; if I attempt to submit the form (with title and body contents and all) by hitting either of the "Post" buttons, the form does not submit, and the label for the empty password field associated with crossposting to LJ turns red, nagging me to populate it. Which I shouldn't need to do if I'm not crossposting.

To post without crossposting, I have to manually turn off the child tickybox (the one specific to crossposting to LJ), and I have to have the parent tickybox ("Crosspost This") on to do so. (When I do, it unticks and grays out the parent tickey box.)

Put another way, unticking the "Crosspost This" ticky box doesn't turn off crossposting; crossposting remains on so long as the child ticky box (indicating the site to crosspost to) is on, and the child ticky box is not unticked by unticking its parent, as is conventional; in that weird state, the form does not submit, and the user is prompted for a password they shouldn't need.

(Also, it took me way too long to figure out what was wrong, because the prompt for the missing password is so low-key, I didn't notice it. (It may have scrolled off the screen at the moment I tried to submit?) All I could tell is that pushing the "post" button did nothing, and I figured it might just be some CSS or JS bug/imcompatibility w/ my browser. Maybe make the "Can't submit, missing required info" notice more prominent?)

FF 48.0.2 on Mac OS 10.6.8.
ghoti: fish jumping out of bowl (Default)

[personal profile] ghoti 2017-04-29 12:04 am (UTC)(link)
Did y'all change something with the auto-complete of tags?

Nevermind. User error. Browser update fixed whatever it was doing.
Edited 2017-04-29 00:14 (UTC)
sireesanwar: (Default)

[personal profile] sireesanwar 2017-05-23 07:23 pm (UTC)(link)
I'm unsure how one would post a video like a youtube video. I thought you would just put the code in but that doesn't seem to work.
darkmagess: (Default)

[personal profile] darkmagess 2017-05-25 01:49 pm (UTC)(link)
Is there no way to insert an image in the Beta page?

Also this seems to be 6 years in beta... Is it ever going to be Actual?
spindizzy: (*jedi powers*)

Account security drop-down on mobile beta page

[personal profile] spindizzy 2017-05-30 11:11 pm (UTC)(link)
Good evening!

Just to let you know, I've had a consistent problem for the last few months while trying to use the mobile version of the beta update page, and I can't find any mention of it on the Current Issues page. The dropdown to change the post security doesn't work at all (cannot select it; is not displayed in the site's style at all) unless I load the page in landscape mode. If I forget and load it while my phone is portrait, turning the phone sideways doesn't fix the problem, I specifically have to reload the page.

This happens every time, and it's fine, I can work around it, it's just an "ugh, forgot AGAIN!" problem, so I thought I'd check to see if anyone else was having this problem. My phone is a Samsung S4, running Chrome version 57.0.2987.132.

Thanks for your time!
spindizzy: (I know what's going on)

Re: Account security drop-down on mobile beta page

[personal profile] spindizzy 2017-06-14 10:25 pm (UTC)(link)
It's a bit odd, yeah! Thank you for doing that, I'm running Android 4.4.2.
kmkamruzzaman: I am an IT & Education related Editor of this news paper (Default)

[personal profile] kmkamruzzaman 2017-06-20 02:50 pm (UTC)(link)
HELLO WORLD
TOMORROW 21 JUNE MY BIRTHDAY.
CONGRATULATION'S EVERYONE.

ALL ARE KNOW THAT I AM AN EDitor-IT & Educaton related on "sangbaddiganta.com in bungladesh.

"Sangbaddiganta.org"
World wide media & publish on github.com,
https://github.com/sangbaddiganta.
I am owner.

But I have a one dream that is
"Sangbaddiganta"-open publish online news paper.
Open software project.
Open publick.
open for everyone.
I have access apache 2.0 version
gtld by kmkamruzzaman.

Thank you
beta.dreamwidth.org
May you help me to success of my dream.

Page 5 of 5

<< [1] [2] [3] [4] [5] >>