denise: Image: Me, facing away from camera, on top of the Castel Sant'Angelo in Rome (Default)
Denise ([staff profile] denise) wrote in [site community profile] dw_beta2011-10-30 11:28 pm
Entry tags:

New Create Entries management page

This post is to report bugs in the new Create Entries page. This is a complete rewrite of the old Update page, in order to allow for future expansion and new features such as draft posts, scheduled posts, recurring posts, expanding the range of what can be posted to your journal, and a whole host of other awesome things.

When reporting bugs, please include:

* The browser name, browser version number, and operating system you're using
* The steps you took to reproduce the problem
* Whether or not you've tested the same steps in another browser (and if so, which)
* Whether you get the same result every time you try the same steps, or if it only happens sometimes

If we can't reproduce the problem under the same browser and operating system, we may also ask you for a list of any browser extensions you have installed.

Not all features are completely implemented in the new Create Entries page yet. The biggest thing currently missing is the Rich Text editor -- the only option is the plain-old-HTML option. The design of the page is geared towards changing concepts and visual/workflow metaphors around what it means to "post an entry", too -- because of the forthcoming draft and scheduled posts, we needed to adapt some of the language and some of the ways we present concepts -- even though the draft and scheduled post functionality isn't ready to be released yet. So, if something looks awkward or like it doesn't quite fit, it's probably there to allow for something we'll be releasing in the future. (You can still mention it, though!)

Things we also consider to be bugs that should be reported, in addition to something not working right:

* if you can't figure out what to do at any step of the update process
* if you have accessibility-related problems (with your screenreader, with the tab order of the page, with the workflow, etc)
* if something about the new workflow completely breaks the way you use your journal, and you can't figure out any way to work around it (there may be a way to do what you're used to doing, but if you can't figure it out, that's something we might change or might want to document, etc)

You can enable or disable beta testing at any point.



Not yet enabled



* Rich Text editing
* Using the new Create Entries page for editing existing entries
* Using the new Create Entries page for comm admins deleting posts or performing admin overrides
* Draft posts of any type, including the in-browser saved drafts that exist right now

Known/Reported Bugs



* some difficulties crossposting, looks like possibly date-related? we're trying to figure it out.

Should be fixed



* Settings not properly saving when using the "gear" customize-this-page popup; some modules disappear
* Create Entries form being repeated after posting an entry
* Error in link to Beta Features at top of page
* Error messages when using new update page in older versions of Firefox
* Difficulties with IE (oh, IE)
* Errors with time being truncated
* inactive icons showing in the icon browser
* minsecurity of journal not reflecting properly in update form
* whole host of display glitches
sara: Lewis and Hathaway frowning at a sheet of paper. (paper frowning)

[personal profile] sara 2011-10-31 04:05 am (UTC)(link)
...so, now, wait -- I turn on beta testing, hit post, and...is something supposed to happen that looks different, or am I doing it wrong?
azurelunatic: A glittery black pin badge with a blue holographic star in the middle. (Default)

[personal profile] azurelunatic 2011-10-31 08:46 am (UTC)(link)
This was unexpected: http://www.diigo.com/item/image/yf91/obik?size=o

Application: Firefox 7.0.1 (20110928134238)
Operating System: WINNT (x86-msvc)

October 31, 2011

- Adblock Plus 1.3.10
Ads were yesterday!
- Add to Amazon Wish List Button 1.7
Add any item from any website to your Amazon Wish List.
- avast! WebRep 6.0.1289 (Disabled)
Web Reputation Plugin
- Awesome screenshot: Capture and Annotate 2.3.3
Capture the whole page or any portion, annotate it with rectangles, circles, arrows, lines and text, blur sensitive info, one-click upload to share.
- bit.ly preview 1.272 (Disabled, Incompatible)
See what lurks beneath those small urls.
- ChatZilla 0.9.87
A clean, easy to use and highly extensible Internet Relay Chat (IRC) client.
- Clippings 3.1.7
Save frequently-entered text for pasting later.
- ColorfulTabs 7.0
Colorful Tabs colors every tab in a different color and makes them easy to distinguish while beautifying the overall appeal of the interface.
- Delicious Bookmarks 2.3.1 (Disabled)
Delicious Bookmarks
- Diigo Toolbar 5.1.0.29 (Disabled)
Bookmark, highlight, and add sticky notes on any web page. Save your bookmarks on the web so you can access them anywhere.
- DOM Inspector 2.0.10
Inspects the structure and properties of a window and its contents.
- Echofon 2.3
Full featured, super clean Twitter app for Firefox.
- Evernote Web Clipper 5.0.0.177572
Provides a button and context menus to easily add a selection or an entire page to Evernote
- Extension List Dumper 1.15.2
Dumps a list of the installed extensions.
- Ghostery 2.6.0.1
Ghostery identifies and allows you to block the 3rd parties (web bugs) that are hidden on the current page you're visiting. Web bugs include ad networks, behavioral data collectors and web analytics providers.
- Google Gears 0.5.36.0 (Disabled, Incompatible)
These are the gears that power the tubes! :-)
- Greasemonkey 0.9.12
A User Script Manager for Firefox
- Java Console 6.0.22 (Disabled, Incompatible)
- Java Console 6.0.26 (Disabled, Incompatible)
- Java Quick Starter 1.0
- Lazarus: Form Recovery 2.3
Recover lost forms with a single click
- LiveJournal Addons 9.5 (Disabled)
Add some facilities to LiveJournal
- Microsoft .NET Framework Assistant 0.0.0
Adds ClickOnce support and the ability to report installed .NET Framework versions to the web server.
- NoScript 2.1.8rc3
Extra protection for your Firefox: NoScript allows JavaScript, Java (and other plugins) only for trusted domains of your choice (e.g. your home-banking web site). This whitelist based pre-emptive blocking approach prevents exploitation of security vulnerabilities (known and even unknown!) with no loss of functionality… Experts will agree: Firefox is really safer with NoScript :-)
- Organize Status Bar 0.6.4 (Disabled, Incompatible)
Organize your status bar icons.
- Popup ALT Attribute 2.0.2011082901
Popups alternate texts of images or others like NetscapeCommunicator(Navigator) 4.x, and show long descriptions in the multi-row tooltip.
- Read It Later 2.1.3
Save pages to read later.
- Stylish 1.2.3
Restyle the web with Stylish, a user styles manager.
- TinEye Reverse Image Search 1.1
Adds TinEye search context menu item for images.
- Wikipedia Lookup Add-on 0.3.8 (Disabled, Incompatible)
Lookup words you select in your browser in Wikipedia in your language.
ivorygates: (Default)

[personal profile] ivorygates 2011-10-31 08:51 am (UTC)(link)
I just tried to change the settings [where you click the gear and you're taken to a page of ticky boxes] but all that does is get rid of tags, comments, icon, and, um, everything but the box for typing the entry into. And I don't seem to be able to get them back...
iosonochesono: (Default)

[personal profile] iosonochesono 2011-10-31 08:57 am (UTC)(link)
So far, I can't seem to move the things to where I would like them.

When I tried to click the settings, all options and forms disappeared, including tags.

I think 'security' and 'filters' would ideally be separated in some way. I have a lot of filters (on LJ, for filtering my friends list over filtering my entries) and it makes my page look all gawky and really long. I don't actually need it on my update page like 99% of the time, but the access/public/private I need way more often.

I'm on Mac 10.5 and have FireFox, btw.

I didn't see the tag brows option, that will be around eventually right? But first I should see if I can get a good look at it again because when I went back to the post page it was showing the old one again... I figure that's because it *just* started :3
musyc: Silver flute resting diagonally across sheet music (Default)

[personal profile] musyc 2011-10-31 09:01 am (UTC)(link)
In the little alert box at the top of the page: To turn off beta testing, visit the beta features page. Clicking the link for "beta features" leads to this URL and a 404: http://www.dreamwidth.org/entry/::SITEROOT/betafeatures


Also, I'm really really really disappointed that the "modules in side column" option is only for "wider windows". Nooooooo, whyyyyyyyyyyyyyyy? That was the primary thing I was interested in. It worked fine on this netbook in the mockups - I'm hoping it will work fine still, but I can't see any modules at all right now to test out whether my window is wide enough. In any case, a notation of just how wide "wider" is would be keen.

ETA: I never remember to mention this. Win7 starter edition, Firefox 6.0.2, several extensions, can list if needed.
Edited (Stats!) 2011-10-31 09:11 (UTC)
tree: a dancer in a black leotard, in the air mid-leap ([else] challenging gravity)

[personal profile] tree 2011-10-31 09:04 am (UTC)(link)
I don't know if this is a bug or if it's just Something I Didn't Know. I opted into the beta testing prior to the code push, then couldn't figure out why I wasn't seeing the sexy new update page. I went back to the beta features page to double check and there are now two sections to opt into. One is "New JS on Journals" and the other is "New Create Entries Page", and I had to click a second "turn on beta testing" button there.

Also, it says that the cut expand and collapse has been implemented, but I still see only the standard ( cut text here ) links. Oh I think that may be covered by the javascript errors that have been reported. Okay!
musyc: Silver flute resting diagonally across sheet music (Default)

[personal profile] musyc 2011-10-31 09:06 am (UTC)(link)
Oh, and! From the settings page with ticky boxes, there's no way to get back to the update page except going to the create menu again. That's non-intuitive for me. I expected clicking the save button to dump me straight back to the update page. Maybe a link somewhere near the save button?
darkicedragon: Kenshin resting on top of Arctic Fox, a red heart in the top left corner (Default)

[personal profile] darkicedragon 2011-10-31 09:11 am (UTC)(link)
XD; Apparently this update doesn't like the Maxthon 2.5.18 browser? I've switched on the beta testing but I get the old update page. I've checked on Internet Explorer and I get the new update page. I'm using Windows 7.

I also can't get back from the page where I try to customise the panels. When I save, I just end up on the customise page.
tree: a black and white photo of a person from the waist down holding a gas mask and a gun ([else] but also not two)

[personal profile] tree 2011-10-31 09:18 am (UTC)(link)
My attempt at creating a poll did nothing. I clicked 'create poll', selected my testing journal [community profile] interalia, made a fake poll, clicked preview, then clicked post poll. That took me back to the create entries page, which was blank. I checked the journal and nothing was posted.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-GB; rv:1.9.2.23) Gecko/20110920 Firefox/3.6.23

ETA: same with Safari 5.1.1
Edited 2011-10-31 09:35 (UTC)
hope: Art of a woman writing from tour poster (Default)

[personal profile] hope 2011-10-31 09:30 am (UTC)(link)
YAAAAY !!!!!!!

Okay, wee bit o' bug reporting:

1. I go into my settings panel, I click around gleefully checking/unchecking panels and getting it how I like it, I check save.

2. WOOT I HAS A CUSTOM UPDATE PAGE. Next, I open the setting panels again, but find that the panels I'd previously checked (still visibly present there on the side) are unchecked.

3. Checking them again results in them disappearing - it seems as if they *think* they are checked (as they should), they're just not *showing* that they're checked.

This is with the side-column enabled, btw.

I'm using Chrome 15.0.874.106 with no javascript-blocking plugins. Edit: and Mac OS X 10.6
Edited 2011-10-31 09:33 (UTC)
tree: text: i am fabulous in bed i can sleep for hours ([else] my favourite place)

[personal profile] tree 2011-10-31 09:30 am (UTC)(link)
I feel like I'm spamming now. :(

I logged in with Safari as well (5.1.1), and I just noticed that the subject line contains the word "Subject" and the text box contains "Your entry text..." which I don't see in Firefox.

ETA: Oooo, clicking on the little gear icon opens the menu on the page rather than loading a new page now \o/. Teh fancy, we has it!
Edited (it's not spamming if you just keep editing your own comments, right?) 2011-10-31 09:32 (UTC)

[personal profile] alexbayleaf 2011-10-31 09:38 am (UTC)(link)
On the "posted successfully" page, the "edit entry" link takes you to the old update page, not the new one.
hope: Art of a woman writing from tour poster (Default)

[personal profile] hope 2011-10-31 09:43 am (UTC)(link)
Huh - now I'm not seeing any panels at all.

From the page I was on, I:

1. clicked the cog icon to collapse the settings - it didn't work, just refreshed the settings panel. Try again several times, same result.

2. Shift+refresh. Now all panels are gone, though I can see their containers (no drag notice visible either). Open settings; all are unchecked. The layout selection remains working, and the bug is still there regardless of which I choose.

3. Checking the panels in the settings panel doesn't make them appear, even after a few shift+refreshes.

ETA: Huh, I just clicked the cog again and it did the same as step 1 (above), but made the droppable areas with the "drag here" text appear!

Again: I'm using Chrome 15.0.874.106 with no javascript-blocking plugins. Edit: and Mac OS X 10.6

ETA: same prob with Safari 5.1.1

ETA the thirdening: Re: step 1, I realise I was clicking the cog to try to collapse again because I was assuming it was a toggle, not just an expander! Perhaps toggling it closed without changes could = cancel?
Edited 2011-10-31 11:19 (UTC)
zaluzianskya: (Coconut // I wonder...)

[personal profile] zaluzianskya 2011-10-31 10:04 am (UTC)(link)
http://transfinite.dreamwidth.org/228429.html

A couple of issues:

1. The icon shown overlaps the dropdown bar on my browser (Firefox 6.0 on Ubuntu 10.10). I tried to recreate the bug in Chromium 14.0.835.202, but none of the items in the settings panel would appear, the same as the beta testers using Google Chrome are reporting.

2. I have a free account, but the icon dropdown is listing and seeming to let me select inactive icons. When I actually post, it defaults to my, well, default icon. Just a little bug there.
copracat: Ronon and Teyla smiling at each other in the foreground, Rodney in the background with text 'John's OT3' (atlantis tsf)

[personal profile] copracat 2011-10-31 11:08 am (UTC)(link)
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.23) Gecko/20110920 Firefox/3.6.23

I have an icon that is 100px wide but less than 100px high (used on this comment). When I choose it as my post icon, it is resized so that its height fits the icons space. It is then wider and overlaps the 'browse' and 'random' buttons.

I have an icon that is 100px high and less than 100px wide. This icon is not distorted on the posting page.

Love the size of the icon browser. About four or five icon images are not showing up, but their alt text is. The icon image shows on the posting page if I chose it.

Icon slightly overlaps the icon chooser drop down box.

I successfully changed the show panels selections ie what I tried to change changed.

I popped back in to settings to change them around again and none of the show panels boxes were ticked. I made some ticks, clicked save and all the panels were gone. (Now there's a clean interface!) I clicked back in to settings and my choices were ticked. I clicked cancel instead of save to see what would happen. No panels. I went in again, my choices were still ticked. I clicked save. No panels. I refreshed the page. I got panels plus there were three tags in the tag box which I had previously deleted using their little X. There should have been no tags listed.

xtina: (Default)

[personal profile] xtina 2011-10-31 12:51 pm (UTC)(link)
Can one put UI requests here, too?  Because I'd like a bit more whitespace between the subject line and the body.  An extra 5px would be fine, according to Stylish.
xtina: "But today, the pattern of lights is *all wrong*!" "Oh god! Try pressing more buttons!" "*It's not helping*!" (tech support)

[personal profile] xtina 2011-10-31 01:10 pm (UTC)(link)
I'm using FF 3.6.23, on Windows 7 Ultimate 32-bit.

* I can't get this to reproduce, so I hardly expect this to be fixed, but I'm listing in case someone else has this issue ever.  When I am on the page such that I can see the userpic widget, but the drop-down would go up instead of down, mousing at all closes the drop-down list.

It's not doing this now, dammit, but it happened before!  *grumpf*

* Steps:

- Click the gear, check "Display Date", and click Save.
- Refresh the page.  Known issue: all widgets are gone.
- Click the gear, check "Reset panels to original settings", and click Save.
- Bug: Two blank boxes between the body and the Post line.

I don't mind refreshing, but...

* UI questions/requests:

*- Is there somewhere for "never mind, clear these fields, start over"?

*- Could "Create Poll" be... well, it goes to a new page, so probably not, but could it be somewhat more stylised?  Or at least put some padding between it and the button to the right of it?

*- After clicking Post Entry, there's no title attribute for the "posted successfully" page.

* Refreshing when I have a draft saves the subject, body, and tags, which is great.  It does not save the mood, userpic, or security setting.  Of these, the last is the one I'm most concerned by.  Could this be changed to remember that selection?
Edited (Adding a thing.) 2011-10-31 13:12 (UTC)
elfin: image:  olivia;  text: invincible (Default)

[personal profile] elfin 2011-10-31 01:20 pm (UTC)(link)
Probably related to the already noted customization settings, but when I load the post-page for the first time, then click the settings gear, the drag-and-drop boxes aren't there. Closing and opening the settings back up gets the boxes to show up. If I reload the page, open the settings again, the drag-and-drop boxes are gone again.

Firefox 7.0.1 on OSX 10.7.2
stormy: βͺ ππŽπ“πˆπ‚π„ ❫ 𝑫𝑢 𝑡𝑢𝑻 𝑻𝑨𝑲𝑬 𝑴𝒀 𝑰π‘ͺ𝑢𝑡𝑺 ⊘ (Default)

[personal profile] stormy 2011-10-31 01:45 pm (UTC)(link)
Mozilla Firefox Aurora 9.0a2 on Windows 7

[ Reproduced ] When you are editing panels, my boxes appear unchecked even though I have the panels showing. They should remain checked for panels that show. If I check a module, it actually makes the module vanish even though the text next to it says "Show panels". On top of this, when I save and load a new Post page, they don't actually show if not clicked. And as other users pointed out, you sometimes have to click the settings button twice for the drag and drop feature to kick in.

[ Graphical Look & Feel ]

[Post As] gets extremely squished indenting the way it is. For 'another user' the word 'user' ends up on a separate line in the wide view, and if used in a side bar 'another user' ends up on en entirely new line nowhere near its radio button.

[Icons]
The browse and random buttons should have a little margin around them, because they're squished together with the bottom of browse on top of the random button. The drop down menu is squished to the bottom of the icon and the random button. It needs some space around it.
cmshaw: Fullmetal Alchemist: Winry repairs Ed's arm (Mechanic)

[personal profile] cmshaw 2011-10-31 01:53 pm (UTC)(link)
How do I order panels? I can tell if this is a bug or something I'm missing.

In Chrome 15 (Windows Vista) I can click on the little gear icon and it tells me "Scroll down to arrange panels to your preference". But when I scroll down, all I find are the panels in the default order. They don't seem to be draggable or clickable anywhere.

In IE 9 (Windows Vista) clicking on the little gear icon takes me to a completely different page with the same checkbox icons but no offer to arrange panels at all. I assume that there's a security setting I need to enable here, but what is it?
kyrielle: A photo of kyrielle, in profile, turned slightly toward the viewer (Default)

[personal profile] kyrielle 2011-10-31 02:22 pm (UTC)(link)
Using Chrome under Windows 7, I initially assumed I couldn't rearrange the modules - pretty much the first thing I wanted to do, as the default arrangement has everything underneath and requires scrolling just to access basic stuff, on my screen. I was able to add the column to the right but couldn't drag and drop.

But there was text saying I could, so I kept trying. I *can* drag and drop, but there are two things that are non-intuitive to me:

1. I can't take an entire boxed module and move it, if I like the contents but want them somewhere else. I have to move elements from that box to another box one at a time. Which is incredibly tedious when the ORDER is right and the POSITION is wrong. This actually is really a pain for me to use since I have to yank them all over to where I want them, then re-order them back to some semblance of what I wanted (unless I manage to be very precise in moving them over, which at least at this hour of the morning, is not my forte).

2. I can't grab an element in the white-space to the side of it. I have to hit on some part of the visual element (edit box, text, etc.). The blank space to the side can't be used. Even though it's part of the same line.
melannen: Commander Valentine of Alpha Squad Seven, a red-haired female Nick Fury in space, smoking contemplatively (Default)

[personal profile] melannen 2011-10-31 03:15 pm (UTC)(link)
There's something weird going on with going in and out of 'settings' - If I'm in 'settings' and I hit the sprocket icon again, it seems to re-load the options box, but the dotted lines around the panels disappear and the alignment of the label changes. If I click the sprocket again, the dotted lines come back and the labels re-left-align. When I click 'save' and make the settings box go away, the labels switch alignment to the opposite of what they were when I clicked "save". This all seems very odd. I would prefer re-clicking the sprocket button to take "settings" away without changing anything, and for the labels in sidebar panels to be left-aligned all the time.

(I'm in Opera 11.52 in Windows XP if it matters. ETA: Same thing is happening on Firefox 3.6.15)
Edited 2011-10-31 16:16 (UTC)
automaticdoor: Carefully recreated screenshot of Britta from Community ep 3x08 captioned "Britta Perry, Anarchist Cat Owner" (Default)

[personal profile] automaticdoor 2011-10-31 03:40 pm (UTC)(link)
I actually have no problems with it so far! It was jarring because it's so different, but I love it. However, I do have one thing that irks me: it now defaults to security level: public when my DW is access list only. I'm afraid I'm going to post without thinking and start creating a ton of public posts, made worse by the fact that I cross-post (friends-locked) to LJ, which would then also be public.
shadowspar: Pic of Kurama holding a rose (kurama - rose)

[personal profile] shadowspar 2011-10-31 03:59 pm (UTC)(link)
Super-slick! Looks great & I love the customizeability. Well done [personal profile] fu. ^_^
Do wishlist items / future enhancement requests go here or straight in the bug tracker? I'd love it if I could throw the panels on the left of the update textarea. Maybe the update area could even be made a panel of sorts or otherwise made draggable as well....? I haven't looked at the underlying code at all, so I'm not sure how big/scary a job that'd be. =)
eruthros: Delenn from Babylon 5 with a startled expression and the text "omg!" (Default)

[personal profile] eruthros 2011-10-31 04:01 pm (UTC)(link)
I don't know if this is a bug or if you just decided not to implement it, but in the mockup there were arrows at the top of each module that could be used to minimize it, and I don't see those at all on the page.

I see the "create poll" link as just text, not a button, and the link text is partly obscured by the preview button.

And some UI things:

I've seen several posts on my rlist from people who didn't know that the gear would let them rearrange modules, which suggests that maybe there needs to be text there as well.

I wish that when I dragged all my modules to the sidebar, they stayed distinct modules - they all turned into one long sidebar module, and since the titles of the modules are no longer grey, it's hard to parse where any one module begins and ends.

... oh wait, I just tried the gear setting again without changing anything, and now they are distinct modules. Hurrah! That is much better!

Page 1 of 5

<< [1] [2] [3] [4] [5] >>