fu: Close-up of Fu, bringing a scoop of water to her mouth (Default)
fu ([personal profile] fu) wrote in [site community profile] dw_beta2012-03-24 01:20 pm

New JS on Journals: Last Call

We're planning on taking the "new JavaScript on journals" changes out of beta soon and making the changes the default for the entire site, so we've done a push today that adds the last few (reported) missing features, and fixes the last few (reported) really annoying behaviors.

There's always going to be one thing more though, so please make sure that you turn on beta for the new JS on journals, and tell us how that new JS works for you -- or doesn't work, if that's the case.

I'm interested in hearing about everything that's bothering you, no matter how tiny it seems! The sooner we know, the sooner we can fix it. (Just this code push, we fixed two things that seemed tiny: one was the hover menu fading way too quickly, another was how the attempt to change your poll vote would bring to you to a separate page instead of changing your vote on the page you were on. They were both things we missed at first, but once they were brought to our attention, we couldn't stop seeing them. And now they're fixed!)

So poke around, and let us know what you find. If you're looking for something to focus on, here's a short list of things we recently added or fixed:

  • added same-page comment tracking

  • fixed same-page changing of poll votes

  • added displaying errors when comment expansion fails to work

  • fixed hover menu fading away even when you didn't move your mouse

  • fixed the .cuttag-open CSS class so it applies to the contents of the opened cut tag (the way the old JS did), for people who want to customize this in their styles

  • made the bottom arrow jump you to the top of the cut tag, without affecting page forward/back

Assuming there are no major issues, we'll turn on the "new JS on journals" beta flag for everyone with our next code push for one last round of testing with the whole site, not just the people who've turned on the beta version. We'll keep it as a beta option at that point, so if anyone has serious problems, they can disable the beta and go back to the old JS while we fix the problem. After that, we'll take this code out of beta and make it the standard option for everyone, removing the old (existing) JavaScript entirely. So, if something's wrong, speak up now!
eyesofstrength: (Default)

[personal profile] eyesofstrength 2012-03-25 03:07 pm (UTC)(link)
I've actually been having issues expanding comments for some time, but I've been opted into the beta for months, just had no idea it was beta related. I have two computers and it only happens on one of them. The other works perfectly fine and is nearly the same setup except OS is different since it's newer.

Affected computer has following setup:

OS: Windows XP (fully updated)
Browser: Firefox 3.6.4
Add-ons: Adblock plus, greasemonkey, ljlogin, noscript (and DW is fully allowed), session manager, tab counter, tab mix plus, tabs menu and youtube to mp3

The computer that works uses same version and has all those add-ons but a few additional ones like Stylish. Only other difference is it uses Windows 7 instead of XP. I can provide a more detailed list of add-ons for the working one later once I'm off work.

And on this computer, expanding works fine in Chrome, but I hate using Chrome on this computer because it will give me a BSOD once a day.
denise: Image: Me, facing away from camera, on top of the Castel Sant'Angelo in Rome (Default)

[staff profile] denise 2012-03-25 03:16 pm (UTC)(link)
Just to gather some data/run some quick exclusion tests:

* If you disable the extensions on the computer you're having problems with, does the problem go away?

* If you only disable LJLogin, does the problem go away? (We have had many, many reports of LJLogin causing all kinds of grief in various ways -- if you're looking for something that will easily let you log in/log out as various accounts, I strongly strongly recommend CookieSwap or a similar full-cookie-profile-swapping extension, instead of LJLogin, until we can do the main/alternate account system we've been planning for a while!)

* Just to clarify (since your comment could've been taken one of two ways) -- is the affected computer the one that Chrome works on, or is that a different computer? In other words: do you have the same problem expanding threads in other browsers on the computer that's having the problem expanding threads in Firefox?
eyesofstrength: (Default)

[personal profile] eyesofstrength 2012-03-25 04:19 pm (UTC)(link)
Okay, just to clarify, affected computer works fine in Chrome.

And to answer your other comment, it's clean on viruses and malware, just ran scans manually to be on the safe side.

Disabling LJLogin only doesn't help at all. Will try the rest here shortly.
denise: Image: Me, facing away from camera, on top of the Castel Sant'Angelo in Rome (Default)

[staff profile] denise 2012-03-25 04:21 pm (UTC)(link)
Gotcha! Okay, thanks.
eyesofstrength: (Default)

[personal profile] eyesofstrength 2012-03-25 04:25 pm (UTC)(link)
And strangely enough, works with all disabled, even though I use all those add ons on the other computer. Will fiddle with it a bit during the day here to figure out which was the problem child and report back on that.
denise: Image: Me, facing away from camera, on top of the Castel Sant'Angelo in Rome (Default)

[staff profile] denise 2012-03-25 04:37 pm (UTC)(link)
Awesome, thank you (knowing which is the problem extension will help us to figure out if we can work around it or if we'll have to tell people to disable that extension, etc)

Quick tip for narrowing it down more easily than just disabling them one at a time: let's say you have 20 extensions installed (just for easy explanation). Start by disabling #1-10 and see if you have the problem: if you do, the problem has to be one of those. (If not, it's with one of the ones in the #11-20 half of the list and you should test with those instead.) Disable half the remaining (so, #s 5-10), test again; if you still have the problem, the issue is with one of the 5 remaining. Disable 4 and 5, test again; if you still have the problem, the issue is with one of the 3 remaining. Etc.

When you hit the point where you aren't having the problem anymore, the issue is with one of the remaining extensions. So, if you disable 4 and 5 and the problem goes away, the problem is with one of those two. Disable 4, test, if you don't have the problem then it was #4; if you do have the problem, it was with #5. This way you can narrow it down more quickly!

It may also be that the issue is with an interaction of more than one extension. To disprove that: once you've got the suspected culprit, disable all extensions but that one, then test again. If the problem still happens, that's good: it means you've definitely found the extension that's causing the issues. (And please do let us know what it is so we can see if we can reproduce the problem ourselves, thus allowing us to work on fixing it!) If the problem doesn't happen with only that extension enabled, it's a conflict with multiple extensions behaving badly with each other, and you're going to have to do some more research, unfortunately.

At that point: enable the problem extension, then repeat the ever-narrowing exclusion tests you did in the first step (so if the problem extension was #4, start with #4 enabled, then #1-10 in addition and see if you have the problem, yadda, each time cutting the # of extensions you have enabled in half but making sure to keep the problem extension as one of them).

Before you do all that, you may want to rule out one more thing: it could be that NoScript is being weird. Try forbidding scripts to run from dreamwidth.org, then go back to NoScript's whitelist and add "dreamwidth.org" back to it (not www.dreamwidth.org) See if doing that helps to prevent the timeout problem?
eyesofstrength: (Default)

[personal profile] eyesofstrength 2012-03-25 05:11 pm (UTC)(link)
It actually was a few extensions. Thankfully I don't have that many on this computer, but all the tab related ones were the issue. So that was tab counter, tab mix plus and tabs menu. I can live without them for now until things are more stable since living without those is better than BSODs that I get with Chrome.
denise: Image: Me, facing away from camera, on top of the Castel Sant'Angelo in Rome (Default)

[staff profile] denise 2012-03-25 05:21 pm (UTC)(link)
Huh. How weird; I don't know why they should be causing problems with loading/executing Javascript, but that is at least good to know! (I have Tab Mix Plus installed myself, and have never had any problems with it; I wonder if it's maybe something about the three of them together?)
eyesofstrength: (Default)

[personal profile] eyesofstrength 2012-03-25 05:52 pm (UTC)(link)
The especially strange part, I could swear my working computer has all three as well. And while I was checking only had one enabled at a time and didn't work with each one, so that rules out interactions as well.

I'll make sure to give the rundown of what my computer that was working has because I'm sure that won't hurt, I just can't access Firefox on it while at work.

Edit: And now it just started doing it again with the same setup we just had working fine. Windows XP machine, firefox 3.6.4 and the add-ons above minus the tab related ones.
Edited 2012-03-25 21:05 (UTC)
eyesofstrength: (Default)

[personal profile] eyesofstrength 2012-03-25 10:44 pm (UTC)(link)
Okay, so to provide some more info. Computer that expanding threads works in in has the following setup:

Windows 7
Firefox 3.6.4
Add-ons: adblock plus, greasemonkey, lj login, noscript, session manager, stop autoplay, tab counter, tab mix plus, stylish, tabs menu, text link, and youtube to mp3

So I was right, both computers have the same overall setup, just this one has Stylish and Text Link instead and Windows 7. Expanding works great here except an every now and then error that fixes itself with a refresh. About the only thing that seems to work for sure to get the other computer to expand threads is to turn off beta testing. For now I'm just going to leave a tab open with that because I'd rather toggle the beta testing than use chrome. Chrome and my other computer do not play nice with each other at all, so at least you got it somewhat working with a workaround in Firefox for me and that's something I can deal with until the bug causing that is found.
eyesofstrength: (Default)

[personal profile] eyesofstrength 2012-03-27 02:22 pm (UTC)(link)
No error. What happens is it does a spinning thing like it will load and then just sits there. I've tried leaving it open to see if it will load and it will stay sitting there spinning away all day if I let it.

And to answer your below question, site skin only. Troposphereical red and purple have both been tried. I don't use custom pages at all.

My main computer does every now and then get something about no response, basically spins gives an error, I refresh and it works. Never get an error on the secondary that hates expanding, it just sits there forever. So maybe it's not even sending anything out for some reason?
eyesofstrength: (Default)

[personal profile] eyesofstrength 2012-03-27 03:14 pm (UTC)(link)
Got that one above for you, site skin only on both computers. I tend to use tropospherical purple or red.

Thanks for the timely response, you and Denise are definitely awesome and have me in a better position than I was before at least even if it's not fully resolved.