fu: Close-up of Fu, bringing a scoop of water to her mouth (Default)
fu ([personal profile] fu) wrote in [site community profile] dw_beta2012-03-24 01:20 pm

New JS on Journals: Last Call

We're planning on taking the "new JavaScript on journals" changes out of beta soon and making the changes the default for the entire site, so we've done a push today that adds the last few (reported) missing features, and fixes the last few (reported) really annoying behaviors.

There's always going to be one thing more though, so please make sure that you turn on beta for the new JS on journals, and tell us how that new JS works for you -- or doesn't work, if that's the case.

I'm interested in hearing about everything that's bothering you, no matter how tiny it seems! The sooner we know, the sooner we can fix it. (Just this code push, we fixed two things that seemed tiny: one was the hover menu fading way too quickly, another was how the attempt to change your poll vote would bring to you to a separate page instead of changing your vote on the page you were on. They were both things we missed at first, but once they were brought to our attention, we couldn't stop seeing them. And now they're fixed!)

So poke around, and let us know what you find. If you're looking for something to focus on, here's a short list of things we recently added or fixed:

  • added same-page comment tracking

  • fixed same-page changing of poll votes

  • added displaying errors when comment expansion fails to work

  • fixed hover menu fading away even when you didn't move your mouse

  • fixed the .cuttag-open CSS class so it applies to the contents of the opened cut tag (the way the old JS did), for people who want to customize this in their styles

  • made the bottom arrow jump you to the top of the cut tag, without affecting page forward/back



Assuming there are no major issues, we'll turn on the "new JS on journals" beta flag for everyone with our next code push for one last round of testing with the whole site, not just the people who've turned on the beta version. We'll keep it as a beta option at that point, so if anyone has serious problems, they can disable the beta and go back to the old JS while we fix the problem. After that, we'll take this code out of beta and make it the standard option for everyone, removing the old (existing) JavaScript entirely. So, if something's wrong, speak up now!
eyesofstrength: (Default)

[personal profile] eyesofstrength 2012-03-25 10:44 pm (UTC)(link)
Okay, so to provide some more info. Computer that expanding threads works in in has the following setup:

Windows 7
Firefox 3.6.4
Add-ons: adblock plus, greasemonkey, lj login, noscript, session manager, stop autoplay, tab counter, tab mix plus, stylish, tabs menu, text link, and youtube to mp3

So I was right, both computers have the same overall setup, just this one has Stylish and Text Link instead and Windows 7. Expanding works great here except an every now and then error that fixes itself with a refresh. About the only thing that seems to work for sure to get the other computer to expand threads is to turn off beta testing. For now I'm just going to leave a tab open with that because I'd rather toggle the beta testing than use chrome. Chrome and my other computer do not play nice with each other at all, so at least you got it somewhat working with a workaround in Firefox for me and that's something I can deal with until the bug causing that is found.
eyesofstrength: (Default)

[personal profile] eyesofstrength 2012-03-27 02:22 pm (UTC)(link)
No error. What happens is it does a spinning thing like it will load and then just sits there. I've tried leaving it open to see if it will load and it will stay sitting there spinning away all day if I let it.

And to answer your below question, site skin only. Troposphereical red and purple have both been tried. I don't use custom pages at all.

My main computer does every now and then get something about no response, basically spins gives an error, I refresh and it works. Never get an error on the secondary that hates expanding, it just sits there forever. So maybe it's not even sending anything out for some reason?