fu: Close-up of Fu, bringing a scoop of water to her mouth (Default)
fu ([personal profile] fu) wrote in [site community profile] dw_beta2013-01-08 01:16 pm

Javascript on Journals: last call ( I mean it this time! )

The last code push included some small and not-so-small fixes to the javascript on journals beta. The biggest visible change is that various items have a completely different look -- this includes dialog boxes on your journal when you try to track comments, and the contextualhover menu. Further details are in my entry to dw-styles (Upcoming changes to contextual hover menu styling (beta) ).

I believe that all the worst bugs for javascript on journals have been reported and fixed. Soon we plan to switch everyone over to the new version, with the ability to opt-out in case any annoying bugs are found once it's had more eyes on it. We'll post about it when that happens.

Please continue to let us know in the comments if you run into any issues, so we can fix them ASAP!
ninetydegrees: Drawing: a girl's face, with a yellow and green stripe over one eye (Default)

[personal profile] ninetydegrees 2013-01-08 08:26 pm (UTC)(link)
Love the new looks! So clean! Noticed that non-square icons get distorted in pop-ups, though.
cheyinka: A glowing blue sheep with green eyes (electric sheep)

[personal profile] cheyinka 2013-01-09 01:24 am (UTC)(link)
Is this the place to report something that still doesn't work (the way I'd expect), or just for new-with-these changes issues?
runpunkrun: combat boot, pizza, camo pants = punk  (Default)

[personal profile] runpunkrun 2013-01-09 02:04 am (UTC)(link)
Okay, so, on site-scheme pages the contextual hover menus look different and have the bigger fonts, as advertised, but on my reading and journal pages the FONT IS ENORMOUS and the box is easily twice as big.
runpunkrun: combat boot, pizza, camo pants = punk  (Default)

[personal profile] runpunkrun 2013-01-09 03:27 am (UTC)(link)
Brilliant! Thank you!
cheyinka: A glowing blue sheep with green eyes (electric sheep)

comment tracking popups

[personal profile] cheyinka 2013-01-09 03:45 am (UTC)(link)
It's the same as what I reported on the s2 comment pages entry (http://dw-beta.dreamwidth.org/13187.html?thread=330115#cmt330115), that in Chrome in Windows or Chromium in FreeBSD, middle-clicking the track this icon doesn't open the more options page in a new tab like it used to in Chrome/ium or still does in Firefox.
ninetydegrees: Drawing: heart in a speech bubble (love)

[personal profile] ninetydegrees 2013-01-09 06:09 am (UTC)(link)
Brilliant! Thank you!
cheyinka: A glowing blue sheep with green eyes (electric sheep)

Re: comment tracking popups

[personal profile] cheyinka 2013-01-09 09:35 pm (UTC)(link)
EEEEEEEEEeeeeeeeeeeeeeeeeeeee yes it works now. (Sorry about any hearing damage from my shriek of glee.)
ninetydegrees: Drawing: lots of yellow pencils (pencils)

[personal profile] ninetydegrees 2013-01-11 02:04 pm (UTC)(link)
I've just realized some of the CSS used in styles to customize pop-ups no longer works. Although we might want to limit what kind of styling's being applied there it was useful to keep it light on dark for example. Haven't looked at the new CSS structure yet so this might just be a consequence of that. Just wanted to mention before I forgot. ;)

Edit: yeah it's just a CSS thing. I'll open a bug for it.
Edited 2013-01-11 14:34 (UTC)
ninetydegrees: Drawing: a girl's face, with a yellow and green stripe over one eye (Default)

[personal profile] ninetydegrees 2013-01-11 04:08 pm (UTC)(link)
Oh missed that. Grabbed it then. Thanks!
truth_is_cold: (Default)

[personal profile] truth_is_cold 2013-01-21 02:50 am (UTC)(link)
If I'm using the mercury browser when I use my Ipad and it uses the default settings for the javascript journal creation, where usually I have a sidebar and other journal options available to use.
eyesofstrength: (003)

[personal profile] eyesofstrength 2013-01-26 06:18 pm (UTC)(link)
I've been noticing something when you go through and use the hide comments option on a thread. Normally the first time it works fine. But if you go and hide the comments on a lower thread a good amount of the time the page scrolls up to the first thread I hid comments on. Yeah, I can scroll back down of course, but that just gets rather frustrating when trying to quickly go through and hide and expand stuff.

Love the new hover menus though. I can finally read them!
eyesofstrength: (003)

[personal profile] eyesofstrength 2013-02-03 03:18 am (UTC)(link)
Sorry for the late response. I have Firefox 5.0.1. Windows 7, Add ons are adblock plus, noscript (which has DW allowed), greasemonkey, ljlogin, screengrab, stop autoplay, stylish, tab counter, tab mix plus, and tabs menu.

One page where it happens a lot is here: http://luceti.dreamwidth.org/5691.html?page=21#comments

Basically I go through the apps there to enter them into the game's spreadsheet. As I finish one, I like to hide the comments so I know it's done and expand the ones that aren't done.

One time I did notice that the link changed acting like I had commented there when I hadn't, but the more recent time it did not. But to give an idea of what happened here's a more specific instance. I went to hide the comments in this thread since the player never responded on revisions. When I did so, it scrolled up to a point in this thread. I hadn't actually linked the threads, that is more to give an idea of where I was and where it went to on that page. It tends to do that after I have hid comments on at least one thread and the location varies, just tends to be around another hidden thread, often about a third of the way down, so this gets more frustrating the further down I get.
shinbunshinobi: icon of Sasuke with his attention gotten (Wait--Did you say pay raise?)

[personal profile] shinbunshinobi 2013-03-01 04:49 am (UTC)(link)
I have been having trouble deleting my own comments in another's post. I tried both in Firefox and Chrome, but clicking the delete button did nothing. It didn't even bring up a hover menu. Turning off the beta JS testing did let me delete the comment. So, I think there might be something there.
shinbunshinobi: icon of Sasuke with his attention gotten (Wait--Did you say pay raise?)

[personal profile] shinbunshinobi 2013-03-01 05:19 am (UTC)(link)
I view entries in the site style, and I have it set to view comment pages in my style, which is still the site style.

I turned it back on and did the same thing. This is the comment I'm trying to delete. Nothing happens.

The Javascript Console gave me this:

Uncaught TypeError: Object [object Object] has no method 'uniqueId' www.dreamwidth.org:34
d.widget._create www.dreamwidth.org:34
(anonymous function) www.dreamwidth.org:31
b.Widget._createWidget www.dreamwidth.org:31
b.(anonymous function).(anonymous function) www.dreamwidth.org:31
(anonymous function) www.dreamwidth.org:31
bG.extend.each www.dreamwidth.org:14
bG.fn.bG.each www.dreamwidth.org:14
b.fn.(anonymous function) www.dreamwidth.org:31
(anonymous function) www.dreamwidth.org:34
bG.event.dispatch www.dreamwidth.org:14
b6.handle.b4 www.dreamwidth.org:14
shinbunshinobi: icon of Sasuke with a book (History forgot the Gundam and motorhorse)

[personal profile] shinbunshinobi 2013-03-01 05:33 am (UTC)(link)
Not a problem!

And nope. I don't. I only have the new JS and new create entries betas turned on.
shinbunshinobi: icon of Sasuke with a book (History forgot the Gundam and motorhorse)

[personal profile] shinbunshinobi 2013-03-01 06:00 am (UTC)(link)
No, thank you! You guys all do a fantastic job. =D
misskat: Picture of Kat with black plastic frames (Default)

[personal profile] misskat 2013-03-25 01:19 pm (UTC)(link)
http://www.dreamwidth.org/support/see_request?id=21519 showed up. Turning off the JS beta fixed the issue. Only happening in Chrome for her. FF is fine.
denise: Image: Me, facing away from camera, on top of the Castel Sant'Angelo in Rome (Default)

[staff profile] denise 2013-03-25 01:22 pm (UTC)(link)
i'm not reproducing at all in chrome with beta on, so there's something obscure going on and we need more info.
cloudsinvenice: woman resting her head on her hand, thinking (Default)

[personal profile] cloudsinvenice 2013-08-13 08:49 pm (UTC)(link)
Hi, I've run into a problem crossposting in beta. Normally it works fine, but when I crossposted just now, the post didn't appear on LJ (though it did crosspost to Insanejournal fine). I went in to edit the DW post and found that the "crosspost to LJ" box was unchecked. I rechecked it and submitted the post again, and got the usual message saying it had requested to crosspost to LJ, but the post still didn't appear there. I've gone through this a few times, and it's always the same - when I go into "edit post" in DW, I find the box unchecked, recheck it, submit (and the box visibly stays checked), but the problem recurs.

I'm using Chrome Version 21.0.1180.90 (can't update it because I'm on OSX 5, but I've been crossposting merrily until today, so I doubt it's my aged browser).
denise: Image: Me, facing away from camera, on top of the Castel Sant'Angelo in Rome (Default)

[staff profile] denise 2013-08-13 08:55 pm (UTC)(link)

That means that the crosspost failed (check your inbox); LJ has been having problems crossposting lately.

box_of_doom: meditation (Default)

[personal profile] box_of_doom 2013-08-16 06:16 pm (UTC)(link)
Perhaps I'm just not sure where to look, but I'm not sure how to/if it is possible to stop the crossposting of individual posts on the beta entries page? It just says that it will be, and gives me no way of deciding whether or not this will happen. (I can choose which DW account, but not uncheck my lj account if I don't want it crossposted to there.)
denise: Image: Me, facing away from camera, on top of the Castel Sant'Angelo in Rome (Default)

[staff profile] denise 2013-08-17 03:25 am (UTC)(link)

Go to the "Settings" link in the upper right hand corner, check (or uncheck) whatever boxes you want and drag and drop them to wherever you'd like.

avaragarda: A dune crest in Erg Chebbi, Morocco, under a blue sky (and the moment's gone)

[personal profile] avaragarda 2013-09-01 11:18 pm (UTC)(link)
This is a little finicky request: in the original Post an Entry form, in HTML mode there's a checkbox to toggle "Disable Auto-Formatting" for the automatic <br> tags and such that get rendered when a post is published. This has been removed from the beta Create Entries page.

It's not a huge thing to have gone, but it does make it easier to give posts advanced styling if we have the option of turning that off (so that <td>s etc. can be visually separated a bit more instead of having a solid block of text to avoid extraneous linebreaks).
Edited 2013-09-01 23:18 (UTC)
denise: Image: Me, facing away from camera, on top of the Castel Sant'Angelo in Rome (Default)

[staff profile] denise 2013-09-01 11:22 pm (UTC)(link)

It just hasn't been implemented yet. We're still looking for a good way to present it in the beta update page. In the meantime, you can disable auto-formatting around a portion of text by surrounding it in ... tags.

avaragarda: Rocks scattered across the Adrar Reg in Mauritania, a bleached white branch lying among them. (crumbles to the ground)

[personal profile] avaragarda 2013-09-02 04:30 am (UTC)(link)
As in <...>unformatted

text here?</...>
denise: Image: Me, facing away from camera, on top of the Castel Sant'Angelo in Rome (Default)

[staff profile] denise 2013-09-02 07:35 pm (UTC)(link)
*facepalm* Sorry, that was me forgetting to escape. <raw-code> (text here) </raw-code>.
wordweaverlynn: (mac)

[personal profile] wordweaverlynn 2013-09-14 11:51 am (UTC)(link)
I can't find a way to add an image to a new post.

Firefox 23.01
Mac OS 10.6.8
denise: Image: Me, facing away from camera, on top of the Castel Sant'Angelo in Rome (Default)

[staff profile] denise 2013-09-14 11:57 am (UTC)(link)

A WYSIWYG-type editor hasn't been implemented yet in the new update page! Until then, you can use the HTML <img> tag.

love: (Default)

[personal profile] love 2013-09-27 04:28 am (UTC)(link)
Hi! I'm sorry if this is unrelated to the current code push, since I only just noticed: the journal entry compose page now has customizable panels, which is nifty, but the panels don't act the way I expect them to when I click checkboxes. They aren't persistent (I keep unchecking Currents, why does it keep coming back? Whereas I keep re-checking Comments and they keep disappearing!)
denise: Image: Me, facing away from camera, on top of the Castel Sant'Angelo in Rome (Default)

[staff profile] denise 2013-09-27 04:31 am (UTC)(link)

That sounds as though your preferences aren't being saved! When you customize your options on the beta customize page, are you certain to hit the "Save" button?

love: (Default)

[personal profile] love 2013-09-27 04:36 am (UTC)(link)
Yup! The first time it happened, I thought, "Oh, duh, save button." But even though I made sure to do that afterwards, I keep getting checkboxes that uncheck/check by themselves! I made changes, hit Save, and then realized I'd forgotten X box, and when I clicked Settings again, the checkboxes were in the old pattern (I always notice Currents and Comments, because I _DON'T_ want Currents, and want Comments.)

If it helps, I'm on Windows 7, and in this iteration I'm using IE 10.0.9. (Two accounts, different browsers. The other account still uses the old compose style because I found the beta aggravating a LONG time ago when the beta was new.)
Edited 2013-09-27 04:39 (UTC)