fu: Close-up of Fu, bringing a scoop of water to her mouth (Default)
fu ([personal profile] fu) wrote in [site community profile] dw_beta2013-01-08 01:16 pm

Javascript on Journals: last call ( I mean it this time! )

The last code push included some small and not-so-small fixes to the javascript on journals beta. The biggest visible change is that various items have a completely different look -- this includes dialog boxes on your journal when you try to track comments, and the contextualhover menu. Further details are in my entry to dw-styles (Upcoming changes to contextual hover menu styling (beta) ).

I believe that all the worst bugs for javascript on journals have been reported and fixed. Soon we plan to switch everyone over to the new version, with the ability to opt-out in case any annoying bugs are found once it's had more eyes on it. We'll post about it when that happens.

Please continue to let us know in the comments if you run into any issues, so we can fix them ASAP!
ninetydegrees: Drawing: a girl's face, with a yellow and green stripe over one eye (Default)

[personal profile] ninetydegrees 2013-01-08 08:26 pm (UTC)(link)
Love the new looks! So clean! Noticed that non-square icons get distorted in pop-ups, though.
cheyinka: A glowing blue sheep with green eyes (electric sheep)

[personal profile] cheyinka 2013-01-09 01:24 am (UTC)(link)
Is this the place to report something that still doesn't work (the way I'd expect), or just for new-with-these changes issues?
runpunkrun: combat boot, pizza, camo pants = punk  (Default)

[personal profile] runpunkrun 2013-01-09 02:04 am (UTC)(link)
Okay, so, on site-scheme pages the contextual hover menus look different and have the bigger fonts, as advertised, but on my reading and journal pages the FONT IS ENORMOUS and the box is easily twice as big.
ninetydegrees: Drawing: lots of yellow pencils (pencils)

[personal profile] ninetydegrees 2013-01-11 02:04 pm (UTC)(link)
I've just realized some of the CSS used in styles to customize pop-ups no longer works. Although we might want to limit what kind of styling's being applied there it was useful to keep it light on dark for example. Haven't looked at the new CSS structure yet so this might just be a consequence of that. Just wanted to mention before I forgot. ;)

Edit: yeah it's just a CSS thing. I'll open a bug for it.
Edited 2013-01-11 14:34 (UTC)
truth_is_cold: (Default)

[personal profile] truth_is_cold 2013-01-21 02:50 am (UTC)(link)
If I'm using the mercury browser when I use my Ipad and it uses the default settings for the javascript journal creation, where usually I have a sidebar and other journal options available to use.
eyesofstrength: (003)

[personal profile] eyesofstrength 2013-01-26 06:18 pm (UTC)(link)
I've been noticing something when you go through and use the hide comments option on a thread. Normally the first time it works fine. But if you go and hide the comments on a lower thread a good amount of the time the page scrolls up to the first thread I hid comments on. Yeah, I can scroll back down of course, but that just gets rather frustrating when trying to quickly go through and hide and expand stuff.

Love the new hover menus though. I can finally read them!
shinbunshinobi: icon of Sasuke with his attention gotten (Wait--Did you say pay raise?)

[personal profile] shinbunshinobi 2013-03-01 04:49 am (UTC)(link)
I have been having trouble deleting my own comments in another's post. I tried both in Firefox and Chrome, but clicking the delete button did nothing. It didn't even bring up a hover menu. Turning off the beta JS testing did let me delete the comment. So, I think there might be something there.
misskat: Picture of Kat with black plastic frames (Default)

[personal profile] misskat 2013-03-25 01:19 pm (UTC)(link)
http://www.dreamwidth.org/support/see_request?id=21519 showed up. Turning off the JS beta fixed the issue. Only happening in Chrome for her. FF is fine.
cloudsinvenice: woman resting her head on her hand, thinking (Default)

[personal profile] cloudsinvenice 2013-08-13 08:49 pm (UTC)(link)
Hi, I've run into a problem crossposting in beta. Normally it works fine, but when I crossposted just now, the post didn't appear on LJ (though it did crosspost to Insanejournal fine). I went in to edit the DW post and found that the "crosspost to LJ" box was unchecked. I rechecked it and submitted the post again, and got the usual message saying it had requested to crosspost to LJ, but the post still didn't appear there. I've gone through this a few times, and it's always the same - when I go into "edit post" in DW, I find the box unchecked, recheck it, submit (and the box visibly stays checked), but the problem recurs.

I'm using Chrome Version 21.0.1180.90 (can't update it because I'm on OSX 5, but I've been crossposting merrily until today, so I doubt it's my aged browser).
box_of_doom: meditation (Default)

[personal profile] box_of_doom 2013-08-16 06:16 pm (UTC)(link)
Perhaps I'm just not sure where to look, but I'm not sure how to/if it is possible to stop the crossposting of individual posts on the beta entries page? It just says that it will be, and gives me no way of deciding whether or not this will happen. (I can choose which DW account, but not uncheck my lj account if I don't want it crossposted to there.)
avaragarda: A dune crest in Erg Chebbi, Morocco, under a blue sky (and the moment's gone)

[personal profile] avaragarda 2013-09-01 11:18 pm (UTC)(link)
This is a little finicky request: in the original Post an Entry form, in HTML mode there's a checkbox to toggle "Disable Auto-Formatting" for the automatic <br> tags and such that get rendered when a post is published. This has been removed from the beta Create Entries page.

It's not a huge thing to have gone, but it does make it easier to give posts advanced styling if we have the option of turning that off (so that <td>s etc. can be visually separated a bit more instead of having a solid block of text to avoid extraneous linebreaks).
Edited 2013-09-01 23:18 (UTC)
wordweaverlynn: (mac)

[personal profile] wordweaverlynn 2013-09-14 11:51 am (UTC)(link)
I can't find a way to add an image to a new post.

Firefox 23.01
Mac OS 10.6.8
love: (Default)

[personal profile] love 2013-09-27 04:28 am (UTC)(link)
Hi! I'm sorry if this is unrelated to the current code push, since I only just noticed: the journal entry compose page now has customizable panels, which is nifty, but the panels don't act the way I expect them to when I click checkboxes. They aren't persistent (I keep unchecking Currents, why does it keep coming back? Whereas I keep re-checking Comments and they keep disappearing!)